What's your idea?

Display sleeps despite unchecked "Allow Display To Sleep" option on High Sierra

After upgrading to Hight Sierra the display sleeps despite the option "Allow Display To Sleep" being unchecked.

7 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Roland shared this idea  ·   ·  Admin →

    3 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • Charles commented  · 

        I'm having the same problem on High Sierra 10.13.3 Macbook Pro 15" 2017

      • Julia commented  · 

        Hi William,

        I tried your second tip, but it doesn't work...

      • AdminWilliam Gustafson (Developer, Instinctual Flaw) commented  · 

        Hi,

        You can try a SMC reset to see if that fixes the issue:
        https://support.apple.com/en-us/HT201295

        Also you can try deleting Amphetamine’s preferences:
        • Quit Amphetamine
        • Launch Terminal.app (/Applications//Utilities/Terminal.app)
        • Type ‘defaults delete com.if.Amphetamine’ without quotes in a Terminal window and press return
        • Re-launch Amphetamine

        Hope this helps.

        Will

      Feedback and Knowledge Base